Service Performance Issues

Incident Report for SNOMED International Tooling

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 08:14 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2025 - 08:09 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 01, 2025 - 08:00 UTC

Investigating

We are receiving reports of performance issues with this service. The team are currently investigating and will post an update shortly.
Posted Apr 01, 2025 - 07:49 UTC
This incident affected: Confluence.