Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 07, 2024 - 18:00 UTC
Scheduled
This service will be undergoing planned maintenance from Thursday 07 November 2024, 18:00UTC until Friday 08 November 2024, 02:00UTC. During this time the service will be unavailable. To allow WCI to update to MedDRA 27.1.
Posted Nov 07, 2024 - 09:42 UTC
This scheduled maintenance affected: MEDdra Mapping Service.